41 lines
967 B
Nix
41 lines
967 B
Nix
{ self, config, lib, nixpkgs, pkgs, ... }:
|
|
|
|
let
|
|
|
|
in
|
|
{
|
|
imports = [
|
|
./hardware-configuration.nix
|
|
./../../configuration.nix
|
|
];
|
|
|
|
# Bootloader.
|
|
boot.loader.systemd-boot.enable = true;
|
|
boot.loader.efi.canTouchEfiVariables = true;
|
|
boot.loader.efi.efiSysMountPoint = "/boot/efi";
|
|
|
|
# Setup keyfile
|
|
boot.initrd.secrets = {
|
|
"/crypto_keyfile.bin" = null;
|
|
};
|
|
|
|
networking.hostName = "mira";
|
|
# Enable swap on luks
|
|
boot.initrd.luks.devices."luks-8aa0584a-df60-42c3-adc2-d88b85544c85".device = "/dev/disk/by-uuid/8aa0584a-df60-42c3-adc2-d88b85544c85";
|
|
boot.initrd.luks.devices."luks-8aa0584a-df60-42c3-adc2-d88b85544c85".keyFile = "/crypto_keyfile.bin";
|
|
|
|
hardware.graphics = {
|
|
enable = true;
|
|
|
|
extraPackages = with pkgs; [
|
|
## amdvlk: an open-source Vulkan driver from AMD
|
|
amdvlk
|
|
vaapiVdpau
|
|
libvdpau-va-gl
|
|
];
|
|
|
|
extraPackages32 = [ pkgs.driversi686Linux.amdvlk ];
|
|
};
|
|
|
|
hardware.bluetooth.enable = true;
|
|
}
|