28 lines
719 B
Nix
28 lines
719 B
Nix
{ self, config, lib, nixpkgs, pkgs, ... }:
|
|
|
|
let
|
|
|
|
in
|
|
{
|
|
imports = [
|
|
./hardware-configuration.nix
|
|
./../../configuration.nix
|
|
];
|
|
|
|
# Bootloader.
|
|
boot.loader.systemd-boot.enable = true;
|
|
boot.loader.efi.canTouchEfiVariables = true;
|
|
boot.loader.efi.efiSysMountPoint = "/boot/efi";
|
|
|
|
# Setup keyfile
|
|
boot.initrd.secrets = {
|
|
"/crypto_keyfile.bin" = null;
|
|
};
|
|
|
|
networking.hostName = "framework";
|
|
# Enable swap on luks
|
|
boot.initrd.luks.devices."luks-20e33e39-6349-4763-ab23-c14cde35055f".device = "/dev/disk/by-uuid/20e33e39-6349-4763-ab23-c14cde35055f";
|
|
boot.initrd.luks.devices."luks-20e33e39-6349-4763-ab23-c14cde35055f".keyFile = "/crypto_keyfile.bin";
|
|
|
|
hardware.bluetooth.enable = true;
|
|
}
|